Installing iOS 5 Beta 1: Error Code 3002

Monday, 06 June 2011

I was getting an Error 3002 when trying to update my iPhone 4 to use the new iOS 5 Beta. Although it doesn't seem to say it anywhere, you need to use a Restore option to install it. (Instead of an update.)

Just be sure to do a backup first. You'll be prompted to restore from an iTunes backup right on the device after the restore process is complete. Then you'll be good to go with all of your existing data.

Happy Testing!